Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: PMP Race Car Eagle Talon

  1. #1
    PMP Motorsports Feedback Score 0
    Join Date
    Apr 2011
    Owner Since

    Location
    Utah
    Posts
    21
    Thanks
    0
    Thanked 2 Times in 2 Posts

    PMP Race Car Eagle Talon

    I can't figure out if Jason has posted about this here already or not so forgive me if he has. We had a decent night at the track last week so I thought it was time it was posted up.

    This is a 92 Talon AWD with the following-

    Built trans
    PMP Build short block and head.
    Dual walbro -8 fuel set up
    FP 88 HTA DBB
    AEM EMS
    Speed Density set up
    Car went on a Super diet
    BC280 cams
    Tinned rear
    Full Cage
    Centerline wheels
    M/T's all around
    Lots of other things but this covers the big things


















  2. #2
    PMP Motorsports Feedback Score 0
    Join Date
    Apr 2011
    Owner Since

    Location
    Utah
    Posts
    21
    Thanks
    0
    Thanked 2 Times in 2 Posts
    Here are some more pictures




















  3. #3
    PMP Motorsports Feedback Score 0
    Join Date
    Apr 2011
    Owner Since

    Location
    Utah
    Posts
    21
    Thanks
    0
    Thanked 2 Times in 2 Posts











  4. #4
    PMP Motorsports Feedback Score 0
    Join Date
    Apr 2011
    Owner Since

    Location
    Utah
    Posts
    21
    Thanks
    0
    Thanked 2 Times in 2 Posts
    To update to that update we switched some things around last week on the car and went to E85, got 2150s injectors and then had a decent run at the track last Friday.

    First run at 10 psi no running issues, bad launch
    2.17 60'
    13.25 @110

    Second run at unknown boost, it didn't save log for some reason. Ran into rps signal issue
    1.9 60'
    1/8th mph 96.34
    12.057 @101

    The MPH shows the big problem on this last run.
    Third run @ 15PSI
    1.69 60'
    11.77 @115

    The car is set up to run 35 psi now but I can't get the resolution in the RPM signal to turn it up, headed out right now to try a couple of ideas for fixing it.

    Here is the video of the run:


    And a vi on my phone of Jason picking up the car haha


  5. #5
    1st ever COTM and COTY verified Feedback Score 9 (100%) green-lantern's Avatar
    Join Date
    Aug 2010
    Owner Since
    Birth

    Location
    Tennessee
    Posts
    7,254
    Thanks
    654
    Thanked 459 Times in 354 Posts
    Very cool! I hope the business is doing well. Tell Jason don't be a stranger.

    Quote Originally Posted by HilbillyHomeboy View Post
    I bet she smells of old mustard and sawdust.
    Jeremy

  6. #6
    Relax, it's just rocket science! Feedback Score 13 (100%) BigTyla's Avatar
    Join Date
    Sep 2010
    Owner Since
    Nov 2001

    Location
    Ozark, AL
    Posts
    1,220
    Blog Entries
    2
    Thanks
    55
    Thanked 122 Times in 76 Posts
    Quote Originally Posted by Jocelynn View Post
    So much space!

  7. #7
    11 sec FWD! (old name: 94atxvr2) Feedback Score 0 11secondFWD's Avatar
    Join Date
    Sep 2010
    Owner Since
    2004 ****Click my home page for videos*****

    Location
    Toledo OH
    Posts
    364
    Thanks
    2
    Thanked 4 Times in 4 Posts
    Is there a finished engine bay pic? Not too bad of runs. With that turbo you should be flying though. That is 16g territory, hopefully you get the bugs worked out and start flying. You going to the shootout?

    I see alot that is similiar top my setup too. same slicks, wheels look close, I have 2 inline 255s, I have the same fuel filter and fuel rail, I have 2150s on e85, same fp manifold. Why are you on AEM instead of dsmlink? It is so simple and easy. I have SD too. And it is so easy to tune. I know AEM can have better potential but link has made over 1000 whp.

    I would have went L19 head studs though. The regular arp suck for power.
    Last edited by 11secondFWD; 08-04-2011 at 07:26 PM.

    92 Eagle Talon TSI AWD Auto = 10.61@127.8 (1.4 60ft)
    94 3000gt SL 8:1TT 5spd getrag = 11.87@123 (1.8 60ft)
    91 3000gt VR4 13gs = 11.61@115 (1.59 60ft)

  8. #8
    Forum User verified Feedback Score 1 (100%) PMP's Avatar
    Join Date
    Sep 2010
    Owner Since
    2003

    Location
    Utah
    Posts
    52
    Thanks
    1
    Thanked 4 Times in 2 Posts
    Quote Originally Posted by 11secondFWD View Post
    Is there a finished engine bay pic? Not too bad of runs. With that turbo you should be flying though. That is 16g territory, hopefully you get the bugs worked out and start flying. You going to the shootout?

    I see alot that is similiar top my setup too. same slicks, wheels look close, I have 2 inline 255s, I have the same fuel filter and fuel rail, I have 2150s on e85, same fp manifold. Why are you on AEM instead of dsmlink? It is so simple and easy. I have SD too. And it is so easy to tune. I know AEM can have better potential but link has made over 1000 whp.

    I would have went L19 head studs though. The regular arp suck for power.

    Sure I can get some more pictures when I get a second to think. The only clean run was at 10 psi and 15 psi.. I believe I have fixed the issue now so I will be back at the track tomorrow with it cranked up. I will not be at the shootout.

    AEM is my weapon of choice.. Nothing wrong with link but I tune AEM and am a dealer so why not go with it?

    Car made 480WHP at 19 psi.

    Oh and there are L19 head studs in it now, did that when I switched injectors etc. Ill be out again tomorrow, expecting 10's at the very least 9's if all goes 'according to plan'.
    '92 charcoal GTO
    '91 red SL
    '91 red vr4
    '94 red vr4

  9. #9
    | @/|/| +|2()|/| verified Feedback Score 6 (100%) terrets's Avatar
    Join Date
    Sep 2010
    Owner Since
    December 2009

    Location
    Fox Cities, WI
    Posts
    1,144
    Thanks
    93
    Thanked 18 Times in 17 Posts
    Now that is a drag car! lol...Nice work, make sure to get video tomorrow

  10. #10
    11 sec FWD! (old name: 94atxvr2) Feedback Score 0 11secondFWD's Avatar
    Join Date
    Sep 2010
    Owner Since
    2004 ****Click my home page for videos*****

    Location
    Toledo OH
    Posts
    364
    Thanks
    2
    Thanked 4 Times in 4 Posts
    Quote Originally Posted by PMP View Post
    Sure I can get some more pictures when I get a second to think. The only clean run was at 10 psi and 15 psi.. I believe I have fixed the issue now so I will be back at the track tomorrow with it cranked up. I will not be at the shootout.

    AEM is my weapon of choice.. Nothing wrong with link but I tune AEM and am a dealer so why not go with it?

    Car made 480WHP at 19 psi.

    Oh and there are L19 head studs in it now, did that when I switched injectors etc. Ill be out again tomorrow, expecting 10's at the very least 9's if all goes 'according to plan'.
    Sweet. That is great for that psi. How long til full spool with that turbo? Good luck on future runs. Ok thats a good reason to run aem.

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
The 3000GT/Stealth/GTO Web History Project
3000gt.com
3000GT / Stealth International WWWboard Archive
Jim's (RED3KGT) Reststop
3000GT/Stealth/GTO Information and Resources
Team 3S
3000GT / Stealth / GTO Information
daveblack.net
3000GT/Stealth/GTO Clubs and Groups
Michigan 3S
MInnesota 3S
Wisconsin 3S
Iowa, Nebraska, Kansas 3S
North California 3000GT/Stealth
United Society of 3S Owners
3000GT/Stealth/GTO Forums
3000GT/Stealth International
3000GT/Stealth/GTO Event Pages
3S National Gathering
East Coast Gathering
Upper Mid-West Gathering
Blue Ridge Gathering