Results 1 to 8 of 8

Thread: High idle

  1. #1
    Forum User Not Verified Feedback Score 0
    Join Date
    Sep 2010
    Owner Since

    Posts
    10
    Thanks
    0
    Thanked 0 Times in 0 Posts

    High idle

    I'm having some issues with high idle. I replaced the tb shaft seals to fix a large boost leak, but that didn't fix the idle. I included a list of things I have noticed while trying to troubleshoot this. I'm still learning how to work on this car so i'm not sure if all of this is relevant.

    Can someone please point me in the right direction for troubleshooting this?

    Issues:
    - Idle sometimes stays up at 2000 RPM for 3-4 seconds when I stop at a stoplight. It will usually drop in steps somewhere in this range- 1500 rpm, 1200 rpm, then sometimes down to around 900 rpm.
    - Turning the steering wheel all they way in either direction does not raise the idle.
    - Biss screw all the way in, car still idles around 900rpm
    - AC on drops the idle from 1200 to 900
    - heater drops it more to 680-700 RPM.
    - Turning off the climate control unit makes the idle go back to 1200 RPM.
    - I had a short in a wire going to the ac control unit (black box under digital climate control unit) - not sure if it's related.
    - The screen for the digital climate control unit sometimes does not light up.
    - I hooked up a data logger and noticed that the AC clutch is always off and the AC switch is always on. Also, the Power steering always says Not Active.



    - I also found this on the firewall. It's melted to where you can see some red inside the wire. Not sure what this is.

    Last edited by mrbaseball; 07-04-2011 at 03:14 AM.

  2. #2
    Australia verified Feedback Score 0 GTOX's Avatar
    Join Date
    Sep 2010
    Owner Since

    Location
    Melbourne, Australia
    Posts
    345
    Thanks
    13
    Thanked 12 Times in 8 Posts
    Have you tested and or replaced the IAC (or whatever we're calling them these days)?

    I had same symptoms as you and a new IAC was the solution, quite a common problem with our cars too...
    Kangaroo

  3. #3
    Forum User Not Verified Feedback Score 0
    Join Date
    Sep 2010
    Owner Since

    Posts
    10
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Quote Originally Posted by GTOX View Post
    Have you tested and or replaced the IAC (or whatever we're calling them these days)?

    I had same symptoms as you and a new IAC was the solution, quite a common problem with our cars too...
    I tested mine with a multimeter per the service manual and it was OK. I read some threads that people replaced it even after testing OK, and it fixed their idle issues. I'm considering ordering a new one if I can't find anything else causing the issues.

  4. #4
    Australia verified Feedback Score 0 GTOX's Avatar
    Join Date
    Sep 2010
    Owner Since

    Location
    Melbourne, Australia
    Posts
    345
    Thanks
    13
    Thanked 12 Times in 8 Posts
    If you do go that route try to get a cheap second hand one from a forum member or even a new one from here DSMISC Automotive (New ISC Supplier) most other places and dealers charge out the ass for them...

  5. #5
    The one. The only. verified
    supporter
    Feedback Score 14 (100%) stealthee's Avatar
    Join Date
    Sep 2010
    Owner Since
    August 28, 2002

    Location
    SWPA
    Posts
    4,012
    Thanks
    169
    Thanked 682 Times in 513 Posts
    You can get one from Rock Auto for $80 so even DSM IAC is charging out the ass.

    [06-05, 19:29] OhioSpyderman: Brian, finding a woman is NOT the answer, you need to shop for a good VACUUM

  6. #6
    Forum User Not Verified Feedback Score 0
    Join Date
    Sep 2010
    Owner Since

    Posts
    10
    Thanks
    0
    Thanked 0 Times in 0 Posts
    I updated Hand Held Halo and now it's showing that the power steering is active all the time. I'm assuming this is the power steering pressure switch. Could that be causing the high idle?


  7. #7
    Forum User Not Verified Feedback Score 4 (100%) TUFFTR's Avatar
    Join Date
    Sep 2010
    Owner Since

    Posts
    760
    Thanks
    27
    Thanked 13 Times in 9 Posts
    Quote Originally Posted by stealthee View Post
    You can get one from Rock Auto for $80 so even DSM IAC is charging out the ass.
    Are the rock auto ones Genuine OEM like the DSMISC's? if not I'd rather pay the extra $60 for an OEM unit.

  8. #8
    The one. The only. verified
    supporter
    Feedback Score 14 (100%) stealthee's Avatar
    Join Date
    Sep 2010
    Owner Since
    August 28, 2002

    Location
    SWPA
    Posts
    4,012
    Thanks
    169
    Thanked 682 Times in 513 Posts
    Yes they are. They are the black top units too.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
The 3000GT/Stealth/GTO Web History Project
3000gt.com
3000GT / Stealth International WWWboard Archive
Jim's (RED3KGT) Reststop
3000GT/Stealth/GTO Information and Resources
Team 3S
3000GT / Stealth / GTO Information
daveblack.net
3000GT/Stealth/GTO Clubs and Groups
Michigan 3S
MInnesota 3S
Wisconsin 3S
Iowa, Nebraska, Kansas 3S
North California 3000GT/Stealth
United Society of 3S Owners
3000GT/Stealth/GTO Forums
3000GT/Stealth International
3000GT/Stealth/GTO Event Pages
3S National Gathering
East Coast Gathering
Upper Mid-West Gathering
Blue Ridge Gathering