Page 1 of 3 123 LastLast
Results 1 to 10 of 23

Thread: Anyone running a 98-99 SL (DOHC) ECU in their VR4?

  1. #1
    Forum User Feedback Score 0
    Join Date
    Jun 2011
    Owner Since

    Posts
    113
    Thanks
    1
    Thanked 4 Times in 3 Posts

    Anyone running a 98-99 SL (DOHC) ECU in their VR4?

    Just wondering how this turned out. I have 2 in the mail, and wondering if they are working good. Thnx!

  2. #2
    Forum User verified Feedback Score 2 (100%) J-Groove's Avatar
    Join Date
    Sep 2010
    Owner Since
    November 1999

    Location
    Rowlett
    Posts
    1,308
    Thanks
    458
    Thanked 98 Times in 66 Posts
    I don't see why not, you can re-flash them as a VR-4 ECU.

    You will need a boomsling adapter to plug it into your existing wire harness depending on what year you are.
    -John

  3. #3
    Forum User Feedback Score 0
    Join Date
    Jun 2011
    Owner Since

    Posts
    113
    Thanks
    1
    Thanked 4 Times in 3 Posts
    Im wondering if someone actually did it, and ran into any unknown problems. I have both the adapter harness and the flash cable. Just dont have the ecu's yet.

  4. #4
    Forum User Not Verified Feedback Score 0
    Join Date
    Sep 2010
    Owner Since
    2002

    Location
    Monterey Bay, CA
    Posts
    31
    Thanks
    2
    Thanked 0 Times in 0 Posts
    I swapped a 99 SL ECU into my 93 stealth, seems to work just fine as far as I can tell. Only thing I've noticed that doesn't work is the boost gauge. To be honest I haven't had a lot of time to play with it. The car's been sitting in my garage for the last several months.. I need to get around to fine tuning the injector scaling/latency and play with the fuel maps a bit one of these days.

  5. #5
    Forum User Feedback Score 0
    Join Date
    Jun 2011
    Owner Since

    Posts
    113
    Thanks
    1
    Thanked 4 Times in 3 Posts
    Sounds promising.. I have one sitting in my P.O. box

  6. #6
    Forum User Feedback Score 0
    Join Date
    Jun 2011
    Owner Since

    Posts
    113
    Thanks
    1
    Thanked 4 Times in 3 Posts
    Quote Originally Posted by yellowstealth View Post
    I swapped a 99 SL ECU into my 93 stealth, seems to work just fine as far as I can tell. Only thing I've noticed that doesn't work is the boost gauge. To be honest I haven't had a lot of time to play with it. The car's been sitting in my garage for the last several months.. I need to get around to fine tuning the injector scaling/latency and play with the fuel maps a bit one of these days.
    What did you do about the missing fuel circuit?

  7. #7
    I lack color... verified
    Feedback Score 1 (100%) Greg E's Avatar
    Join Date
    Sep 2010
    Owner Since
    Aug 1998

    Posts
    3,601
    Thanks
    104
    Thanked 500 Times in 242 Posts
    Quote Originally Posted by Drummer View Post
    What did you do about the missing fuel circuit?
    The car will still run, just will stay at the high setting all the time. Hot wiring your fuel pump eliminates this circuit anyway.

    2014 Exomotive Exocet - #101 "shocker yellow" - 1.8L 5-speed 3.9 torsen FMII powered
    Read more: http://mevowners.proboards.com/threa.../greg-pa-build

    99 Solano Black VR4 - #16 of 287 - ground up restoration - sold
    98 Pearl White VR4 #54 of 231 - 12.84@105mph - 93 Octane 12.50@107mph - 100 Octane with Chromed ECU - sold
    99 Pearl White VR4 #108 of 287 - 3RD place stock car class ECG 11 - Sold
    98 Black VR4: 100% stock - totalled by an Illegal 2-12-08
    95 White Stealth TT - 11.852 @ 118.25 - sold
    95 SSG Stealth TT - 11.981 @ 115.81mph - sold

    "I don't actually work on cars, I just talk about them on the internet."

  8. #8
    Forum User Feedback Score 0
    Join Date
    Jun 2011
    Owner Since

    Posts
    113
    Thanks
    1
    Thanked 4 Times in 3 Posts
    Quote Originally Posted by Greg E View Post
    The car will still run, just will stay at the high setting all the time. Hot wiring your fuel pump eliminates this circuit anyway.
    Nice. I dont have to touch anything then... for now!

  9. #9
    I lack color... verified
    Feedback Score 1 (100%) Greg E's Avatar
    Join Date
    Sep 2010
    Owner Since
    Aug 1998

    Posts
    3,601
    Thanks
    104
    Thanked 500 Times in 242 Posts
    Quote Originally Posted by Drummer View Post
    Nice. I dont have to touch anything then... for now!
    Well, you're still going to have to put the 99 ROM onto it and then you'll get a Check Engine Light from not having any emissions equipment.

  10. #10
    Forum User Feedback Score 0
    Join Date
    Jun 2011
    Owner Since

    Posts
    113
    Thanks
    1
    Thanked 4 Times in 3 Posts
    I have those things covered :P I should have said " I dont have to touch any HARDWARE yet"

Page 1 of 3 123 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
The 3000GT/Stealth/GTO Web History Project
3000gt.com
3000GT / Stealth International WWWboard Archive
Jim's (RED3KGT) Reststop
3000GT/Stealth/GTO Information and Resources
Team 3S
3000GT / Stealth / GTO Information
daveblack.net
3000GT/Stealth/GTO Clubs and Groups
Michigan 3S
MInnesota 3S
Wisconsin 3S
Iowa, Nebraska, Kansas 3S
North California 3000GT/Stealth
United Society of 3S Owners
3000GT/Stealth/GTO Forums
3000GT/Stealth International
3000GT/Stealth/GTO Event Pages
3S National Gathering
East Coast Gathering
Upper Mid-West Gathering
Blue Ridge Gathering