Results 1 to 8 of 8

Thread: Put on custom exhaust and afg gauge... my afr is 17... HLEP

  1. #1
    Member verified Feedback Score 0
    Join Date
    Nov 2010
    Owner Since

    Location
    Iowa
    Posts
    66
    Thanks
    4
    Thanked 0 Times in 0 Posts

    Angry Put on custom exhaust and afg gauge... my afr is 17... HLEP

    Title pretty well states it... 91 RT/TT stock fuel system, vacuum reduction deleted fuel solenoid... Pressure tested to 10psi and I think its holding rather well... For some reason after I started it the afr was reading 17 to pegging the meter... When I revved it would rise to about 15 or so and come back to 17... Im not sure what would be causing this. Could the gauge be bad? It was new in box when I bought it... Boost leak somewhere? Or should I let it warm up and take a cruse and see what it does? I was afraid to tonight upon gettin gthat reading... My car seems to be in a state of everything going wrong right now
    ~RABBIT~

    1991 Dodge Stealth RT/TT - In the garage... Close to completion...
     photo sig1.jpg

  2. #2
    Forum User Not Verified Feedback Score 0 Keyan's Avatar
    Join Date
    Sep 2010
    Owner Since

    Posts
    573
    Thanks
    22
    Thanked 15 Times in 13 Posts
    Exhaust leak before the sensor. If it was idling that high you'd feel it.

    [Droid X via Tapatalk]
    Recertified ASE L1/L3 Master Technician
    13G's on Pump 93 tuned to 421awhp/419awtq @ 17psi tuned by Pampena Motorsports ....375awtq at 2900rpm....
    Billet 19T HL's on E85 tuned to .....?

  3. #3
    Forum User Feedback Score 2 (100%) Maximal's Avatar
    Join Date
    Sep 2010
    Owner Since
    2001

    Location
    Avoca, NY
    Posts
    1,247
    Thanks
    7
    Thanked 58 Times in 40 Posts
    Yep, sounds like an exhaust leak (and a decent one at that) before the sensor.

    What type of gauge is it? Some require calibration so that could be it also.

  4. #4
    Member verified Feedback Score 0
    Join Date
    Nov 2010
    Owner Since

    Location
    Iowa
    Posts
    66
    Thanks
    4
    Thanked 0 Times in 0 Posts
    I absolutely love that that is the first two answers I got... It's an aem digital gauge... And now that you mention it my girlfriend did say she saw smoke near the firewall... I did not see it tho... I'll try and do some checking today...

  5. #5
    Forum User Feedback Score 2 (100%) Maximal's Avatar
    Join Date
    Sep 2010
    Owner Since
    2001

    Location
    Avoca, NY
    Posts
    1,247
    Thanks
    7
    Thanked 58 Times in 40 Posts
    The AEM's don't require calibration so chances are you've got a decent size leak somewhere...probably big enough to hear.

  6. #6
    Member verified Feedback Score 0
    Join Date
    Nov 2010
    Owner Since

    Location
    Iowa
    Posts
    66
    Thanks
    4
    Thanked 0 Times in 0 Posts
    I'm going to drop the dp and check for holes in the rear precat housing... I might have caught it with the drill.... After that I guess all that's left is the bolts/gaskets... I do have a Pretty loud lifter tic on the rear bank tho... With my head in there I can't hear much else...

  7. #7
    Forum User verified
    Feedback Score 1 (100%)
    Join Date
    Sep 2010
    Owner Since
    1

    Posts
    1,291
    Thanks
    77
    Thanked 89 Times in 55 Posts
    Where is the o2 bung located? I assume since this is a custom exhaust they welded on a bung for it somewhere. Check for pinholes around the bung. Even the smallest one here can cause a major problem since it's right at the sensor. Ran into this when the previous owner(worst ever) "welded" bungs on JDM precats.

  8. #8
    Member verified Feedback Score 0
    Join Date
    Nov 2010
    Owner Since

    Location
    Iowa
    Posts
    66
    Thanks
    4
    Thanked 0 Times in 0 Posts
    The bung is on the DP... Its a tanabe ebay knockoff... Its right after where the rear pipe meets the main pipe... Ill try and dig up a pic...



    Its the one closest to the flex section....

    I also have a youtube video now... I have 2 videos of me driving around but my phone wont let me upload them without a wifi connection... They should be up in the next couple days and Ill link them on here..


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
The 3000GT/Stealth/GTO Web History Project
3000gt.com
3000GT / Stealth International WWWboard Archive
Jim's (RED3KGT) Reststop
3000GT/Stealth/GTO Information and Resources
Team 3S
3000GT / Stealth / GTO Information
daveblack.net
3000GT/Stealth/GTO Clubs and Groups
Michigan 3S
MInnesota 3S
Wisconsin 3S
Iowa, Nebraska, Kansas 3S
North California 3000GT/Stealth
United Society of 3S Owners
3000GT/Stealth/GTO Forums
3000GT/Stealth International
3000GT/Stealth/GTO Event Pages
3S National Gathering
East Coast Gathering
Upper Mid-West Gathering
Blue Ridge Gathering