Page 1 of 2 12 LastLast
Results 1 to 10 of 19

Thread: Little help...

  1. #1
    Forum User Feedback Score 0
    Join Date
    May 2011
    Owner Since
    2005

    Location
    Metairie, LA
    Posts
    21
    Thanks
    4
    Thanked 0 Times in 0 Posts

    Little help...

    Alright, got a 92TT in the works been sitting for 5+ years and now it time to see what i can do with it. Everything works but the engine. She'll turn over, no spark and no fuel. Everything points to either an ECU problem or a combination fouled MFI relay/ignition coil. What is the more likely problem to be? Local dodge dealership wants $50 just to plug it in and give me the error codes, which I don't want to do. Wondering if anyone else has had a similar problem and can shed some light for me.

  2. #2
    Twin Turbo verified Feedback Score 5 (100%) GTOJOE's Avatar
    Join Date
    Sep 2010
    Owner Since
    2007

    Location
    Melbourne, Australia
    Posts
    2,155
    Thanks
    79
    Thanked 92 Times in 76 Posts
    Having no spark and no fuel does seem to point to an ECU. It is very common to have on but not the other... but having neither is odd. Do you have an aftermarket alarm system? Many alarms will cut both of these.
    1990 JDM GTO TT with Vi-PEC plug-in V44 EMS, TD04-13T's, 3SX Downpipe, MP Hi-flow cat, ARC SMIC's, Aeromotive Stealth 340LPH pump, Fuelab 515 FPR, Ninja Performance 75amp hotwire kit, oohnoo fuel loop & rail adapters, Nylon braided ethanol fuel line, NGK AFX Wideband, K&N FIPK, Iridium plugs, HKS Twin Power DLI, Turbo XS racing BOV, 3SX poly mounts, Custom 280km/h speedo.

    Waiting install
    Injector Dynamics 725cc Injectors.

    Build Thread

  3. #3
    Here for the party Not Verified Feedback Score 1 (100%) CoreyB's Avatar
    Join Date
    Sep 2010
    Owner Since
    2006

    Location
    Canaan NH
    Posts
    1,749
    Thanks
    368
    Thanked 108 Times in 89 Posts
    Pull the ECU and check for leaky capacitors. Stealth 316 - ECM Removal

  4. The Following User Says Thank You to CoreyB For This Useful Post:


  5. #4
    Forum User Feedback Score 0
    Join Date
    May 2011
    Owner Since
    2005

    Location
    Metairie, LA
    Posts
    21
    Thanks
    4
    Thanked 0 Times in 0 Posts
    Quote Originally Posted by GTOJOE View Post
    Having no spark and no fuel does seem to point to an ECU. It is very common to have on but not the other... but having neither is odd. Do you have an aftermarket alarm system? Many alarms will cut both of these.

    Very interesting that you would bring that up. I just cut out an aftermarket alarm and remote start(jerry rigged as its a 5spd) that previous owner put in. Theoretically though tht would have fixed the problem would it not?

  6. #5
    Forum User Feedback Score 0
    Join Date
    May 2011
    Owner Since
    2005

    Location
    Metairie, LA
    Posts
    21
    Thanks
    4
    Thanked 0 Times in 0 Posts
    big thanks on the link... helpful yet depressing. guess I've gott dust off the old soldering iron...

  7. #6
    Twin Turbo verified Feedback Score 5 (100%) GTOJOE's Avatar
    Join Date
    Sep 2010
    Owner Since
    2007

    Location
    Melbourne, Australia
    Posts
    2,155
    Thanks
    79
    Thanked 92 Times in 76 Posts
    Quote Originally Posted by peterkottemann View Post
    Very interesting that you would bring that up. I just cut out an aftermarket alarm and remote start(jerry rigged as its a 5spd) that previous owner put in. Theoretically though tht would have fixed the problem would it not?
    Yes in theory this would resolve that. But it's possible it wasn't removed correctly or you forgot to plug something back in when doing it???

    Quote Originally Posted by peterkottemann View Post
    big thanks on the link... helpful yet depressing. guess I've gott dust off the old soldering iron...
    Does this mean you have checked and there are leaking caps?

  8. #7
    Forum User Feedback Score 0 box's Avatar
    Join Date
    Jan 2011
    Owner Since

    Posts
    198
    Thanks
    3
    Thanked 29 Times in 20 Posts
    Quote Originally Posted by peterkottemann View Post
    Very interesting that you would bring that up. I just cut out an aftermarket alarm and remote start(jerry rigged as its a 5spd) that previous owner put in. Theoretically though tht would have fixed the problem would it not?
    provided you properly bipassed the immobiliser (i.e. you didnt just unplug the alarm) then you should be fine. So your ECU had leaky caps then?

  9. #8
    Forum User Feedback Score 0
    Join Date
    May 2011
    Owner Since
    2005

    Location
    Metairie, LA
    Posts
    21
    Thanks
    4
    Thanked 0 Times in 0 Posts
    yes, leaking caps unfortunately. everything was reconnected correctly, some electronics that were previously inoperable now work and my radio is picking up stations from 150 miles away now. I'll be tearingmy ecu open this week. I figure even if I screw something up I'm no worse off...

  10. #9
    Here for the party Not Verified Feedback Score 1 (100%) CoreyB's Avatar
    Join Date
    Sep 2010
    Owner Since
    2006

    Location
    Canaan NH
    Posts
    1,749
    Thanks
    368
    Thanked 108 Times in 89 Posts

  11. The Following User Says Thank You to CoreyB For This Useful Post:


  12. #10
    Forum User Feedback Score 0
    Join Date
    May 2011
    Owner Since
    2005

    Location
    Metairie, LA
    Posts
    21
    Thanks
    4
    Thanked 0 Times in 0 Posts
    I occasionally repair circuit boards at work, process is almost identical only we use 409 instead of straight acetone, slightly less corrosive I guess.

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
The 3000GT/Stealth/GTO Web History Project
3000gt.com
3000GT / Stealth International WWWboard Archive
Jim's (RED3KGT) Reststop
3000GT/Stealth/GTO Information and Resources
Team 3S
3000GT / Stealth / GTO Information
daveblack.net
3000GT/Stealth/GTO Clubs and Groups
Michigan 3S
MInnesota 3S
Wisconsin 3S
Iowa, Nebraska, Kansas 3S
North California 3000GT/Stealth
United Society of 3S Owners
3000GT/Stealth/GTO Forums
3000GT/Stealth International
3000GT/Stealth/GTO Event Pages
3S National Gathering
East Coast Gathering
Upper Mid-West Gathering
Blue Ridge Gathering