Page 1 of 5 123 ... LastLast
Results 1 to 10 of 42

Thread: These silicone radiator hoses wont stop leaking

  1. #1
    Forum User verified Feedback Score 0
    Join Date
    Jan 2011
    Owner Since

    Posts
    119
    Thanks
    1
    Thanked 2 Times in 2 Posts

    These silicone radiator hoses wont stop leaking

    So last year I made a couple bad decisions.

    1) The budget was running low, so I went with some knock-off silicone radiator hoses from china-bay.
    2) I filled the car with whatever coolant I found at autozone.


    No matter how much I tighten these hoses they WILL leak, and they not only leak when hot but they also leaked just sitting. The hose clamps are on so tight that the hoses are about to be damaged. My second mistake really isnt that bad, but since these pipes keep leaking I can see how gross and goo-ish this coolant really is, which makes me wonder what gross-ness is building inside my very clean and fresh engine.

    I refuse to believe that I NEED t-bolt clamps for radiator hoses, so is it just the case that my Chinese silicone doesnt make a very good seal...? If so, I will just buy something nicer tomorrow and get them in before the weekend. The car is coming out of winter storage this weekend.

    Thanks,
    Jay

  2. #2
    Forum User Feedback Score 0
    Join Date
    Sep 2010
    Owner Since

    Posts
    12
    Thanks
    0
    Thanked 0 Times in 0 Posts
    What brand, or website did you get them from?

  3. #3
    1st ever COTM and COTY verified Feedback Score 9 (100%) green-lantern's Avatar
    Join Date
    Aug 2010
    Owner Since
    Birth

    Location
    Tennessee
    Posts
    7,254
    Thanks
    654
    Thanked 459 Times in 354 Posts
    If you are using stock clamps then that is your problem. Get better clamps, my samco hoses leaked with stock clamps. New regular clamps worked but I got T clamps later.

    Quote Originally Posted by HilbillyHomeboy View Post
    I bet she smells of old mustard and sawdust.
    Jeremy

  4. #4
    Forum User Not Verified Feedback Score 3 (100%)
    Join Date
    Nov 2010
    Owner Since
    2007

    Location
    Midland,MI
    Posts
    175
    Thanks
    0
    Thanked 1 Time in 1 Post
    get the upper one from 3sx in the "one off parts" section. very thick hose then buy 2 t bolts the hoses are only 15 bucks

  5. #5
    Forum User verified
    Feedback Score 1 (100%)
    Join Date
    Sep 2010
    Owner Since
    1

    Posts
    1,294
    Thanks
    77
    Thanked 89 Times in 55 Posts
    I have a polished stainless upper pipe with silicone couplers. I had the same issue with regular worm clamps and stock clamps. After going with tclamps not a drop since.

  6. #6
    Forum User Not Verified Feedback Score 4 (100%) TUFFTR's Avatar
    Join Date
    Sep 2010
    Owner Since

    Posts
    760
    Thanks
    27
    Thanked 13 Times in 9 Posts
    If not, use a bit of vaso under the hose so it creates a seal? Just a suggestion if your not using worm clamps..

  7. #7
    Forum User verified Feedback Score 0
    Join Date
    Jan 2011
    Owner Since

    Posts
    119
    Thanks
    1
    Thanked 2 Times in 2 Posts
    hm, interesting. I guess I will go ahead and put on t-bolt clamps.

    I am currently using worm clamps, not the stock clamps. Hopefully I haven't damaged the hoses the badly, silicone started pushing through the little holes in the worm clamp because I tightened then so much..

    I have no idea what brand they are. I cant find then on e-bay anymore.

    -EDIT- They are OBX hoses, half the cost of the samco.

  8. #8
    Forum User Not Verified Feedback Score 4 (100%) TUFFTR's Avatar
    Join Date
    Sep 2010
    Owner Since

    Posts
    760
    Thanks
    27
    Thanked 13 Times in 9 Posts
    Very strange man, I have OBX hoses on both cars, with worm clamps and have never ever had a leak!

  9. #9
    STL3S Not Verified Feedback Score 0
    Join Date
    Sep 2010
    Owner Since
    Oct 2005

    Posts
    192
    Thanks
    37
    Thanked 39 Times in 27 Posts
    My OBX hoses leaked as well, and as soon as I got them nice and tight, they started weeping out of imperfections in the hose itself!

    Guess who's going back to stock!

    Pretty disappointing, since several other STL folks got their hoses the same time I got mine, and we're all switching back.

  10. #10
    Forum User verified Feedback Score 0
    Join Date
    Jan 2011
    Owner Since

    Posts
    119
    Thanks
    1
    Thanked 2 Times in 2 Posts
    Quote Originally Posted by whitedragon View Post
    My OBX hoses leaked as well, and as soon as I got them nice and tight, they started weeping out of imperfections in the hose itself!

    Guess who's going back to stock!

    Pretty disappointing, since several other STL folks got their hoses the same time I got mine, and we're all switching back.
    hm, whelp I can order some samcos and have them before the weekend, or I get try the clamps...

    Anyone else have the same experience as whitedragon and I?

Page 1 of 5 123 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
The 3000GT/Stealth/GTO Web History Project
3000gt.com
3000GT / Stealth International WWWboard Archive
Jim's (RED3KGT) Reststop
3000GT/Stealth/GTO Information and Resources
Team 3S
3000GT / Stealth / GTO Information
daveblack.net
3000GT/Stealth/GTO Clubs and Groups
Michigan 3S
MInnesota 3S
Wisconsin 3S
Iowa, Nebraska, Kansas 3S
North California 3000GT/Stealth
United Society of 3S Owners
3000GT/Stealth/GTO Forums
3000GT/Stealth International
3000GT/Stealth/GTO Event Pages
3S National Gathering
East Coast Gathering
Upper Mid-West Gathering
Blue Ridge Gathering