Results 1 to 9 of 9

Thread: Think i narrowed it down to the AEM EMS...

  1. #1
    Forum User Not Verified Feedback Score 3 (100%) Sin'sVr4's Avatar
    Join Date
    Sep 2010
    Owner Since
    2007

    Location
    Pueblo, CO
    Posts
    1,571
    Thanks
    20
    Thanked 17 Times in 17 Posts

    Think i narrowed it down to the AEM EMS...

    i think we figured out maybe what is my issue. we tested all my signal leads and voltages to basically everything fuel and ignition related(to cover all angles). I am getting voltage and resistance to all coils, ptu and cas. (cas pulses when cranking on multimeter). ok, next, getting voltage to the inj harness and to each individual inj harness plug. Now, no spark, and the injectors when cranking are not opening and spitting fuel. So, if everything else is working correctly, and my injectors are not opening to spray fuel, im not gettng spark...seems to point to the AEM? well, can I send it in to have AEM check it out. long day and frustrated and believe I made good progress. Anyone have their aem EMS do this? and could the 6k rev for 4 seconds burn something inside my EMS?


    Mike

    1/4 mile 11.80 @117mph. 551whp 641trq @ 26psi E85 tune, MTC 19T-HLs, forge 15psi spring wastegates, 780 PTE inj, 3SX Fuel loop, ss fuel lines, Engine built by Laniers Speed shop, block bored .060 w/ chromolly rings, weisco pistons, 3sx custom forged rods, forged crank, HKS DLI, AEM EMS, AEM UEGO wideband, prosport oil and boost guages, aeromotive 1000 FPR, Dejon blow thru twintakes, Walbro E85 400 w/ 3sx hotwire kit and custom an fitting fuel pump w/ STM filter to pump line, CXRacing FMIC, Megan Racing Aluminum radiator, IPS custom downpipe, Borla 3" exhaust,Greddy profec b spec II EBC, Blitz SS BOV,R1 Drilled slotted rotors, Drag DR-31 rims, RPS stage 4 unsprung clutch,

  2. #2
    Banned Feedback Score 11 (100%) J. Fast's Avatar
    Join Date
    Sep 2010
    Owner Since
    - O - SIX -

    Location
    Colorado, USA
    Posts
    2,755
    Thanks
    412
    Thanked 203 Times in 143 Posts
    Did you buy the EMS new or used? I believe there box warranty is one year. After that, it's like $300 to go thru the box and test it and make whatever repairs. I've never had one go bad, but apparenly Don and Justin both have.

  3. #3
    Forum User Not Verified Feedback Score 3 (100%) Sin'sVr4's Avatar
    Join Date
    Sep 2010
    Owner Since
    2007

    Location
    Pueblo, CO
    Posts
    1,571
    Thanks
    20
    Thanked 17 Times in 17 Posts
    Bought it from jeffs at IPS's buddy who claimed it was new. didnt bother to look at the seal till today, and they were broken. So, gotta call AEM and find out what I need to do.

    But, plugged in a stock ecu and car fired up first crank. So definitly EMS

  4. #4
    Banned Feedback Score 11 (100%) J. Fast's Avatar
    Join Date
    Sep 2010
    Owner Since
    - O - SIX -

    Location
    Colorado, USA
    Posts
    2,755
    Thanks
    412
    Thanked 203 Times in 143 Posts
    If you have a reciept... maybe you're good? Don't know about the seal thing. I would call Jeff.

  5. #5
    Forum User Not Verified Feedback Score 3 (100%) Sin'sVr4's Avatar
    Join Date
    Sep 2010
    Owner Since
    2007

    Location
    Pueblo, CO
    Posts
    1,571
    Thanks
    20
    Thanked 17 Times in 17 Posts
    ya. I will call him first thing tomm. Kinda felt stupid becuase I didnt want to have the urge to open the box, but both seals were already open. I know for a fact i didnt do it. J, can you flash the AEM to try and reset the board?

  6. #6
    Forum User Not Verified Feedback Score 3 (100%) Sin'sVr4's Avatar
    Join Date
    Sep 2010
    Owner Since
    2007

    Location
    Pueblo, CO
    Posts
    1,571
    Thanks
    20
    Thanked 17 Times in 17 Posts
    sent it back to AEM, $75 to go thru it. Just probably wont get it for 3 weeks back . That sucks. Jeff was off sick today so Ill call him tommorrow.

  7. #7
    Monogamous Gigolo verified Feedback Score 8 (100%) 2fnloud's Avatar
    Join Date
    Sep 2010
    Owner Since
    October 2009

    Location
    Ithaca, Mi.
    Posts
    2,796
    Blog Entries
    3
    Thanks
    616
    Thanked 192 Times in 133 Posts
    is that 75 include the cost to fix? or is that 75 just to tell you whats wrong with it?

  8. #8
    Forum User Not Verified Feedback Score 3 (100%) Sin'sVr4's Avatar
    Join Date
    Sep 2010
    Owner Since
    2007

    Location
    Pueblo, CO
    Posts
    1,571
    Thanks
    20
    Thanked 17 Times in 17 Posts
    not sure, think diag and tehn depends.

  9. #9
    Riding topless!! verified Feedback Score 0 Gearheadvr4's Avatar
    Join Date
    Sep 2010
    Owner Since
    Owned 8 3s since 2005.

    Location
    Corpus Christi
    Posts
    422
    Thanks
    2
    Thanked 29 Times in 10 Posts
    There should be a lifetime warentee on AEM considering how much they cost. Hopefully yours is an easy (cheap) fix.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
The 3000GT/Stealth/GTO Web History Project
3000gt.com
3000GT / Stealth International WWWboard Archive
Jim's (RED3KGT) Reststop
3000GT/Stealth/GTO Information and Resources
Team 3S
3000GT / Stealth / GTO Information
daveblack.net
3000GT/Stealth/GTO Clubs and Groups
Michigan 3S
MInnesota 3S
Wisconsin 3S
Iowa, Nebraska, Kansas 3S
North California 3000GT/Stealth
United Society of 3S Owners
3000GT/Stealth/GTO Forums
3000GT/Stealth International
3000GT/Stealth/GTO Event Pages
3S National Gathering
East Coast Gathering
Upper Mid-West Gathering
Blue Ridge Gathering