Results 1 to 7 of 7

Thread: Installed pcvless valve cover and lines...(pics)

  1. #1
    Forum User Not Verified Feedback Score 3 (100%) Sin'sVr4's Avatar
    Join Date
    Sep 2010
    Owner Since
    2007

    Location
    Pueblo, CO
    Posts
    1,571
    Thanks
    20
    Thanked 17 Times in 17 Posts

    Installed pcvless valve cover and lines...(pics)

    OK, so I finally had time to swap out my new valve cover and rerouted some breather lines. What do you guys think? I have pics of the krank vents in place. I routed the rear and front T line thru the hole where my intercooler pipes go. Came out great
    new line1.jpgline4.jpgline5.jpgline2.jpgline3.jpg

    1/4 mile 11.80 @117mph. 551whp 641trq @ 26psi E85 tune, MTC 19T-HLs, forge 15psi spring wastegates, 780 PTE inj, 3SX Fuel loop, ss fuel lines, Engine built by Laniers Speed shop, block bored .060 w/ chromolly rings, weisco pistons, 3sx custom forged rods, forged crank, HKS DLI, AEM EMS, AEM UEGO wideband, prosport oil and boost guages, aeromotive 1000 FPR, Dejon blow thru twintakes, Walbro E85 400 w/ 3sx hotwire kit and custom an fitting fuel pump w/ STM filter to pump line, CXRacing FMIC, Megan Racing Aluminum radiator, IPS custom downpipe, Borla 3" exhaust,Greddy profec b spec II EBC, Blitz SS BOV,R1 Drilled slotted rotors, Drag DR-31 rims, RPS stage 4 unsprung clutch,

  2. #2
    Banned Feedback Score 11 (100%) J. Fast's Avatar
    Join Date
    Sep 2010
    Owner Since
    - O - SIX -

    Location
    Colorado, USA
    Posts
    2,755
    Thanks
    412
    Thanked 203 Times in 143 Posts
    So the T line for the drivers side just dumps? No catch can?

  3. #3
    Forum User Not Verified Feedback Score 3 (100%) Sin'sVr4's Avatar
    Join Date
    Sep 2010
    Owner Since
    2007

    Location
    Pueblo, CO
    Posts
    1,571
    Thanks
    20
    Thanked 17 Times in 17 Posts
    ya, pretty much. got everything open atmos nw

  4. #4
    1st ever COTM and COTY verified Feedback Score 9 (100%) green-lantern's Avatar
    Join Date
    Aug 2010
    Owner Since
    Birth

    Location
    Tennessee
    Posts
    7,254
    Thanks
    654
    Thanked 459 Times in 354 Posts
    Do you have a valve in the hose coming off the one that connects the heads?

    Quote Originally Posted by HilbillyHomeboy View Post
    I bet she smells of old mustard and sawdust.
    Jeremy

  5. #5
    Forum User Not Verified Feedback Score 3 (100%) Sin'sVr4's Avatar
    Join Date
    Sep 2010
    Owner Since
    2007

    Location
    Pueblo, CO
    Posts
    1,571
    Thanks
    20
    Thanked 17 Times in 17 Posts
    no. basically its one step better than just removing the hose. Wierd thing tho...this morning, started the car to warm it up, idled perfect. reved it acouple of times with the throttle cable. was great. turned it off cause I wasnt leaving for about 30 minutes. came out, started it, immediately went to 6000 like doing a 2step! shut it off. checked the engine bay, throttle cable was off the metal retainer? put it back in, restarted it and was at 2800 rpms? sounds like its sucking alot from the twintakes and like the bov is just surging a bit? never did this until just now? wtf? so I took the audi to work and left her in the garage? hmm? ill try again when i go home for lunch to see if it just needed to reset itself? Just wierd as hell. Shouldnt be the valve cover. Still have the krank vent instead of the pcv.
    Last edited by Sin'sVr4; 03-21-2011 at 02:09 PM.

  6. #6
    1st ever COTM and COTY verified Feedback Score 9 (100%) green-lantern's Avatar
    Join Date
    Aug 2010
    Owner Since
    Birth

    Location
    Tennessee
    Posts
    7,254
    Thanks
    654
    Thanked 459 Times in 354 Posts
    Might want to put a valve in there when you get a chance. Since you still have the hose hooked to the lower intake you will be pulling all kinds of unfiltered air into the engine.
    Last edited by green-lantern; 03-21-2011 at 02:19 PM.

  7. #7
    Forum User Not Verified Feedback Score 3 (100%) Sin'sVr4's Avatar
    Join Date
    Sep 2010
    Owner Since
    2007

    Location
    Pueblo, CO
    Posts
    1,571
    Thanks
    20
    Thanked 17 Times in 17 Posts
    I have a krank vent on there. Picture 4 shows fromt eh valve cover to the lower plenum

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
The 3000GT/Stealth/GTO Web History Project
3000gt.com
3000GT / Stealth International WWWboard Archive
Jim's (RED3KGT) Reststop
3000GT/Stealth/GTO Information and Resources
Team 3S
3000GT / Stealth / GTO Information
daveblack.net
3000GT/Stealth/GTO Clubs and Groups
Michigan 3S
MInnesota 3S
Wisconsin 3S
Iowa, Nebraska, Kansas 3S
North California 3000GT/Stealth
United Society of 3S Owners
3000GT/Stealth/GTO Forums
3000GT/Stealth International
3000GT/Stealth/GTO Event Pages
3S National Gathering
East Coast Gathering
Upper Mid-West Gathering
Blue Ridge Gathering