Page 1 of 2 12 LastLast
Results 1 to 10 of 17

Thread: ok, might have hurt the rear turbo seal?

  1. #1
    Forum User Not Verified Feedback Score 3 (100%) Sin'sVr4's Avatar
    Join Date
    Sep 2010
    Owner Since
    2007

    Location
    Pueblo, CO
    Posts
    1,571
    Thanks
    20
    Thanked 17 Times in 17 Posts

    ok, might have hurt the rear turbo seal?

    Well, alot of you know, I dropped my oil pan to reseal it. drained all the oil, but the oil filter had maybe 200 miles on it so I didnt change it out. Put 5 qts in of 10-30w castrol syntec blend. I was driving Sat and al of a sudden had a ton of smoke behind me. Never happened before. Took her home, pulled out the intake pipes, checked the front turbo, not much shaft play. Checked the rear, minimal shaft play. checked everywhere on block and no leaks, cam seal are good, no leaks. drained about 1/2 qt of oil. just under top notch on dipstick. perfect now. drove it this morning to work...(E85 hates 19 degrees outside starts ) when i would get on it it wuld give a little puff. no smoke at idle, only some on down shifting thats y I think the seal could be bad.

    Im hoping that there is residual oil still being burned off thats y it smokes abit. It doesnt billow out just a little on shifts when I get on it. If I did blow the seal then I have no one to blame but myself on that one.

    When I had my bad 15g's, I dropped the downpipe and at idle and reving it it would smoke like it was on fire coming out of the front bank. It doesnt smoke at all at idle even when I rev it pretty high. so Thats y i am not sure.

    MIke

    1/4 mile 11.80 @117mph. 551whp 641trq @ 26psi E85 tune, MTC 19T-HLs, forge 15psi spring wastegates, 780 PTE inj, 3SX Fuel loop, ss fuel lines, Engine built by Laniers Speed shop, block bored .060 w/ chromolly rings, weisco pistons, 3sx custom forged rods, forged crank, HKS DLI, AEM EMS, AEM UEGO wideband, prosport oil and boost guages, aeromotive 1000 FPR, Dejon blow thru twintakes, Walbro E85 400 w/ 3sx hotwire kit and custom an fitting fuel pump w/ STM filter to pump line, CXRacing FMIC, Megan Racing Aluminum radiator, IPS custom downpipe, Borla 3" exhaust,Greddy profec b spec II EBC, Blitz SS BOV,R1 Drilled slotted rotors, Drag DR-31 rims, RPS stage 4 unsprung clutch,

  2. #2
    -BOOSTTD- verified Feedback Score 2 (100%) mh3kgt's Avatar
    Join Date
    Sep 2010
    Owner Since
    2007

    Location
    Elko, Nevada, United States
    Posts
    578
    Thanks
    34
    Thanked 14 Times in 13 Posts
    Sounds exactly like the problem I'm having. I can let it sit at idle forever and get no smoke, but if I drive around and get into boost and then let off I get a pretty good puff of smoke and then it's gone. Started off with small cloud but recently has gotten worse and now will let out a puff if I rev it at idle and let it come back down, but once it settles at idle smoke is gone. I'm pretty sure it's my rear turbo seals since rear IC pipes have oil and front does not.

  3. #3
    Padawan garage troll Not Verified Feedback Score 1 (100%) Roybatty's Avatar
    Join Date
    Sep 2010
    Owner Since
    2004

    Location
    Newark, DE
    Posts
    672
    Blog Entries
    5
    Thanks
    70
    Thanked 24 Times in 22 Posts
    Quote Originally Posted by mh3kgt View Post
    Sounds exactly like the problem I'm having. I can let it sit at idle forever and get no smoke, but if I drive around and get into boost and then let off I get a pretty good puff of smoke and then it's gone. Started off with small cloud but recently has gotten worse and now will let out a puff if I rev it at idle and let it come back down, but once it settles at idle smoke is gone. I'm pretty sure it's my rear turbo seals since rear IC pipes have oil and front does not.
    I am planning on updating your other thread on PCV valves. I finally got my oil catch can installed where the vapor canistor used to be, with BIG(19mm) tubing. Haven't had a chance to run it WOT yet to see how it handles smoke @ decel after boost.

    OP check your crank venting tubes are not clogged up. Do you have oil in the bubble (leading to the rear turbo)? Its common for the PCV valve to be overrun in our cars.

  4. #4
    Forum User Not Verified Feedback Score 3 (100%) Sin'sVr4's Avatar
    Join Date
    Sep 2010
    Owner Since
    2007

    Location
    Pueblo, CO
    Posts
    1,571
    Thanks
    20
    Thanked 17 Times in 17 Posts
    I have a new pcv valve and DR racing krank vents. I have blow thru so no bubble. No oil in my dejon twin takes either. I am going to pull the the dp tonight and check to see if any smoke comes from the front or rear banks.

  5. #5
    -BOOSTTD- verified Feedback Score 2 (100%) mh3kgt's Avatar
    Join Date
    Sep 2010
    Owner Since
    2007

    Location
    Elko, Nevada, United States
    Posts
    578
    Thanks
    34
    Thanked 14 Times in 13 Posts
    I noticed that I had a bit of oil in my bubble leading to the rear turbo as well. Looks like it was coming from the rear head vent tube that runs into the bubble. I've replaced the PCV since then, but still have a puff of smoke on decel after boost. Would VSS cause any of this? I doubt it since I am seeing oil in my IC piping on rear turbo, sounds more like turbo seals to me but I've been fooled before.

  6. #6
    Forum User Not Verified Feedback Score 3 (100%) Sin'sVr4's Avatar
    Join Date
    Sep 2010
    Owner Since
    2007

    Location
    Pueblo, CO
    Posts
    1,571
    Thanks
    20
    Thanked 17 Times in 17 Posts
    Quote Originally Posted by mh3kgt View Post
    I noticed that I had a bit of oil in my bubble leading to the rear turbo as well. Looks like it was coming from the rear head vent tube that runs into the bubble. I've replaced the PCV since then, but still have a puff of smoke on decel after boost. Would VSS cause any of this? I doubt it since I am seeing oil in my IC piping on rear turbo, sounds more like turbo seals to me but I've been fooled before.
    im telling you this, drop your downpipe, idle the car and look under the car and see if there is anysmoke coming from the front or rear bank. If it is coming from the rear which soulnds like it is...then vuwalauh...bad turbo. vss will smoke on idle more or less. im prety sure its your turbo. Just upgrade or get it rebuilt. Seems like what I might need to do.

  7. #7
    -BOOSTTD- verified Feedback Score 2 (100%) mh3kgt's Avatar
    Join Date
    Sep 2010
    Owner Since
    2007

    Location
    Elko, Nevada, United States
    Posts
    578
    Thanks
    34
    Thanked 14 Times in 13 Posts
    Yeah that was my plan for this coming weekend if I can find the time. I've pretty much ruled out all else but the turbo seals. I've been meaning to drop the DP and check it out that way, but just haven't made the time since I don't drive it that much anymore because of a few issues I'm slowly sorting out. I'm gonna try to rebuild them myself if they're smoking and save up to convert the 9b's I just bought to 19T's

    *EDIT* how many miles have you got on your 19t's now? I think I've got roughly ~1k on mine, but I'm pretty sure I killed the turbo seals by accidentally overfilling it with oil once :facepalm:
    Last edited by mh3kgt; 01-31-2011 at 05:21 PM.

  8. #8
    1st ever COTM and COTY verified Feedback Score 9 (100%) green-lantern's Avatar
    Join Date
    Aug 2010
    Owner Since
    Birth

    Location
    Tennessee
    Posts
    7,254
    Thanks
    654
    Thanked 459 Times in 354 Posts
    I'll post more later but for now, where are you blow through guys running the tube that was on the bubble?

    Quote Originally Posted by HilbillyHomeboy View Post
    I bet she smells of old mustard and sawdust.
    Jeremy

  9. #9
    Forum User Not Verified Feedback Score 3 (100%) Sin'sVr4's Avatar
    Join Date
    Sep 2010
    Owner Since
    2007

    Location
    Pueblo, CO
    Posts
    1,571
    Thanks
    20
    Thanked 17 Times in 17 Posts
    i have a pepsi can...lol

  10. #10
    -BOOSTTD- verified Feedback Score 2 (100%) mh3kgt's Avatar
    Join Date
    Sep 2010
    Owner Since
    2007

    Location
    Elko, Nevada, United States
    Posts
    578
    Thanks
    34
    Thanked 14 Times in 13 Posts
    I'm speed density but am still using the stock bubble for now. When I get twin intakes I plan on just putting a breather filter on the nipple from the rear head to bubble

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
The 3000GT/Stealth/GTO Web History Project
3000gt.com
3000GT / Stealth International WWWboard Archive
Jim's (RED3KGT) Reststop
3000GT/Stealth/GTO Information and Resources
Team 3S
3000GT / Stealth / GTO Information
daveblack.net
3000GT/Stealth/GTO Clubs and Groups
Michigan 3S
MInnesota 3S
Wisconsin 3S
Iowa, Nebraska, Kansas 3S
North California 3000GT/Stealth
United Society of 3S Owners
3000GT/Stealth/GTO Forums
3000GT/Stealth International
3000GT/Stealth/GTO Event Pages
3S National Gathering
East Coast Gathering
Upper Mid-West Gathering
Blue Ridge Gathering