Page 1 of 3 123 LastLast
Results 1 to 10 of 21

Thread: Lifter tick or something more now?

  1. #1
    No Show NG11 Not Verified Feedback Score 0 TwoXist's Avatar
    Join Date
    Sep 2010
    Owner Since
    2005

    Location
    Mesa, AZ
    Posts
    149
    Thanks
    6
    Thanked 3 Times in 3 Posts

    Lifter tick or something more now?

    I noticed around a month ago that the "tick" noise got more prominent. Right around when it got colder outside. My oil pressure has been fine and i haven't had any lights come on. But the 20w50 and lucas trick isn't keeping her quite anymore. Are my lifters just that bad now or do i have a bigger issue? I have two videos (sorry for the quality) one is just with her idling and the other is with some gas.

    http://s107.photobucket.com/albums/m...=VIDEO_014.mp4

    http://s107.photobucket.com/albums/m...IDEO_014-1.mp4
    Last edited by TwoXist; 12-07-2010 at 11:12 PM.
    Your 1993 Mitsubishi 3000GT SL is one of 4310 that received VIN numbers. Based on the order of the serial numbers, your car was the 2685th out of the 4310 that were made that year.

  2. #2
    Member Not Verified Feedback Score 7 (100%) mb3000's Avatar
    Join Date
    Sep 2010
    Owner Since
    '09

    Location
    Myrtle Beach
    Posts
    2,669
    Thanks
    121
    Thanked 133 Times in 97 Posts
    Sounds more like rod knock to me.

  3. #3
    Forum User Feedback Score 0 mikeyVR4's Avatar
    Join Date
    Sep 2010
    Owner Since
    2001

    Location
    Gilbert, AZ
    Posts
    109
    Thanks
    16
    Thanked 3 Times in 3 Posts
    Well is it going away after some time?

    I started my car today and the lifter tick was bad. I just turned the car off and then back on again and the noise was gone. I really do think lifter tick gets louder as it gets colder outside. BTW, I never rev my engine just in case its something else. Just let it warm up and does it go away?

    Rod Knock doesnt go away. Lifter tick does.

  4. #4
    No Show NG11 Not Verified Feedback Score 0 TwoXist's Avatar
    Join Date
    Sep 2010
    Owner Since
    2005

    Location
    Mesa, AZ
    Posts
    149
    Thanks
    6
    Thanked 3 Times in 3 Posts
    It seems to come and go and gets quieter while driving. If i am sitting at a light i can hear it, go to the next light and it will be gone. So i still feel its lifters but not a 100% sure anymore. Might see if Tim has some free time and have him take a look at it.

  5. #5
    Banned Feedback Score 11 (100%) J. Fast's Avatar
    Join Date
    Sep 2010
    Owner Since
    - O - SIX -

    Location
    Colorado, USA
    Posts
    2,755
    Thanks
    412
    Thanked 203 Times in 143 Posts
    Stop running it and open it up... That's a bag of hammers. Have you done a compression test or leakdown? I would guess a min of one cyl is under 100.

  6. #6
    SoSoCal verified Feedback Score 1 (100%) DuTTch's Avatar
    Join Date
    Sep 2010
    Owner Since
    2002

    Posts
    714
    Thanks
    23
    Thanked 31 Times in 23 Posts
    how many miles on it?

  7. #7
    No Show NG11 Not Verified Feedback Score 0 TwoXist's Avatar
    Join Date
    Sep 2010
    Owner Since
    2005

    Location
    Mesa, AZ
    Posts
    149
    Thanks
    6
    Thanked 3 Times in 3 Posts
    I am at 132k But the noise seems to come and go. This morning i started it and nothing. Then it slowly came back but faint and then went away.

  8. #8
    Forum User Feedback Score 0
    Join Date
    Sep 2010
    Owner Since

    Location
    stow
    Posts
    247
    Thanks
    2
    Thanked 17 Times in 12 Posts
    also sounds like rod knock to me. pull the pan and check it before you need a new crank.. 20-50 ??

  9. #9
    Wrench Monkey Not Verified Feedback Score 1 (100%) TwIzTeD_3kGt's Avatar
    Join Date
    Sep 2010
    Owner Since
    2005

    Location
    Rochester, NY
    Posts
    714
    Thanks
    41
    Thanked 26 Times in 19 Posts
    Hard to tell with that crappy sound clip. Could be rod knock, could be a loud lifter. Get a better clip.

    '97 VR4 - 19t, Chrome, Pump 93, 22psi, DD, Since '06
    '95 SL - 150k+, clean, reliable
    '06 Envoy SLT - Black, clean, DD
    '98 Expedition EB- Work/Winter horse
    '93 VR4 & '94 R/T - Projects

  10. #10
    Forum User Feedback Score 0 mikeyVR4's Avatar
    Join Date
    Sep 2010
    Owner Since
    2001

    Location
    Gilbert, AZ
    Posts
    109
    Thanks
    16
    Thanked 3 Times in 3 Posts
    Quote Originally Posted by TwoXist View Post
    I am at 132k But the noise seems to come and go. This morning i started it and nothing. Then it slowly came back but faint and then went away.
    Not sure what everyone is saying. Correct me if I am wrong but a rod knock doesn't come and go.

Page 1 of 3 123 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
The 3000GT/Stealth/GTO Web History Project
3000gt.com
3000GT / Stealth International WWWboard Archive
Jim's (RED3KGT) Reststop
3000GT/Stealth/GTO Information and Resources
Team 3S
3000GT / Stealth / GTO Information
daveblack.net
3000GT/Stealth/GTO Clubs and Groups
Michigan 3S
MInnesota 3S
Wisconsin 3S
Iowa, Nebraska, Kansas 3S
North California 3000GT/Stealth
United Society of 3S Owners
3000GT/Stealth/GTO Forums
3000GT/Stealth International
3000GT/Stealth/GTO Event Pages
3S National Gathering
East Coast Gathering
Upper Mid-West Gathering
Blue Ridge Gathering