Page 2 of 2 FirstFirst 12
Results 11 to 12 of 12

Thread: Stealth Stalls after 15 minutes - Now won't start at all

  1. #11
    Member Not Verified Feedback Score 2 (100%)
    Join Date
    Nov 2010
    Owner Since
    2003

    Posts
    2,061
    Thanks
    113
    Thanked 272 Times in 207 Posts
    This is where a scan tool/data logger that can view live data would help greatly. You just monitor and look for the input that drops out. it's not O2 sensors, the ECU has a 12.5% trim limit on those. MAF is easy enough to test, when it's rough just unplug it and see if it helps, though that also is the test for an intake leak. I'm betting there's a bad wire that becomes an open as the wire itself gets hot, I've seen that before. On Levi's car IIRC one of the PTU wires about a foot from the PTU would fail as it warmed up and acted like bad PTU with no spark.

  2. #12
    Forum User Feedback Score 0
    Join Date
    Aug 2020
    Owner Since
    2006

    Posts
    2
    Thanks
    0
    Thanked 0 Times in 0 Posts
    What kind of diagnostic device would you recommend?

Page 2 of 2 FirstFirst 12

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
The 3000GT/Stealth/GTO Web History Project
3000gt.com
3000GT / Stealth International WWWboard Archive
Jim's (RED3KGT) Reststop
3000GT/Stealth/GTO Information and Resources
Team 3S
3000GT / Stealth / GTO Information
daveblack.net
3000GT/Stealth/GTO Clubs and Groups
Michigan 3S
MInnesota 3S
Wisconsin 3S
Iowa, Nebraska, Kansas 3S
North California 3000GT/Stealth
United Society of 3S Owners
3000GT/Stealth/GTO Forums
3000GT/Stealth International
3000GT/Stealth/GTO Event Pages
3S National Gathering
East Coast Gathering
Upper Mid-West Gathering
Blue Ridge Gathering