Results 1 to 2 of 2

Thread: Hesitation, sputtering-I've gotta get rid of this car!

  1. #1
    Forum User Feedback Score 0
    Join Date
    Sep 2010
    Owner Since

    Posts
    1
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Hesitation, sputtering-I've gotta get rid of this car!

    A Little background first. I've got a 93 SL that I've owned for 6 years and I have taken care of this car pretty well and when I got married, I gave the car to my wife. Anyway I was having a hesitation problem with the car. It was hesitating, sputtering, then dying and would start right back up, check engine light would come on, then it would be okay for a while till the CEL went out, then it would be ready for it's next episode. I changed plugs and installed new wires and it ran better, but it was still doing the same thing. On a suggestion from my son, I took it to Autozone so they could read the codes and tell me what they were. Well, I have a 93, so they couldn't do it. I searched around on the net and decided to read them myself with a voltmeter(Thanks Jeff!). There were 4 codes: airflow sensor, intake air temp sensor, barometric pressure sensor and an injector code. The first 3 are all inside the MAS housing(I think). It seemed strange that they would all go out together. I was shopping for a new MAS and decided to take a look at the plug on the MAS. It looked fine, dry no corrosion and was on tight. I greased up the pins with some of that grease you get when you buy new tail-lights and plugged it back in. My wife and I are So Happy! I started it up and the CEL immediately went off, so we went for a long ride. No problems! I hope someone else has some luck with this. I was imagining the worst - buying a new MAS and still having the same problem. If anyone is having similar issues all I can say is good luck and don't give up too easily.

  2. #2
    TheOmniscientRT Feedback Score 0 TheRedStealth's Avatar
    Join Date
    Sep 2010
    Owner Since

    Location
    Statesville NC
    Posts
    73
    Thanks
    3
    Thanked 0 Times in 0 Posts
    congrats on the easy fix

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
3000GT / Stealth / GTO Resources
3000GT / Stealth / GTO / Multi-site Classifieds
3000GT/Stealth/GTO Event Pages
3S National Gathering
East Coast Gathering
Upper Mid-West Gathering
Blue Ridge Gathering
3000GT/Stealth/GTO Clubs and Groups
Michigan 3S
MInnesota 3S
Wisconsin 3S
Iowa, Nebraska, Kansas 3S
North California 3000GT/Stealth
United Society of 3S Owners
3000GT/Stealth/GTO Forums
3000GT/Stealth International
3000GT/Stealth/GTO Information and Resources
Team 3S
3000GT / Stealth / GTO Information
daveblack.net
The 3000GT/Stealth/GTO Web History Project
3000gt.com
3000GT / Stealth International WWWboard Archive