Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: Like 5-10 MPG literally :(

  1. #1
    BUS LENGTHS Feedback Score 1 (100%)
    Join Date
    Sep 2010
    Owner Since

    Location
    penn, PA
    Posts
    204
    Thanks
    32
    Thanked 2 Times in 2 Posts

    Like 5-10 MPG literally :(

    My car is BPU with the stock fuel pump hotwired. (3 inch turbo back no mufflers/cats, intake, MBC, FULL vac reduction)

    After hot wiring my fuel pump and deleting the fuel pump relay and the fuel pump resistor (http://www.stealth316.com/2-fuelpumprelaybypass.htm) because my car was running lean I seriously have the worst MPG ever. It's really hurting my wallet BAD. What could be the issue? Running too rich?

    I have the chance to buy an AFC for a good price if that would help at all. I am going to log my car tonight in hopes that someone can tell me what's wrong.

    A bad rear turbo wouldn't do this would it? Mine burns oil and is dying.

    Any ideas? Thanks <3

  2. #2
    Forum User Feedback Score 0
    Join Date
    Sep 2010
    Owner Since

    Posts
    198
    Thanks
    5
    Thanked 25 Times in 17 Posts
    sounds like your over running the stock fuel pressure regulator. Fuel trims are probably pegged rich and still not enough to compensate. Your still on stock turbos. I would just keep the wiring stock and maybe upgrade to a walbro. Or get a better FPR

  3. #3
    Member verified
    supporter
    Feedback Score 0 DocWalt's Avatar
    Join Date
    Sep 2010
    Owner Since
    Oct '08 - Oct '10

    Location
    Royersford, PA
    Posts
    3,500
    Blog Entries
    1
    Thanks
    796
    Thanked 394 Times in 277 Posts
    Log it and post your logs. Sounds like either a bad O2 causing it to run super rich, or the FPR over-running. The FPRs are like any other part of the car and can cause issues.
    R135
    ╚╬╬╝
    - 24

  4. #4
    BUS LENGTHS Feedback Score 1 (100%)
    Join Date
    Sep 2010
    Owner Since

    Location
    penn, PA
    Posts
    204
    Thanks
    32
    Thanked 2 Times in 2 Posts
    Thanks!

    Would lowering boost help?

  5. #5
    Forum User Feedback Score 0
    Join Date
    Sep 2010
    Owner Since

    Location
    Kentucky
    Posts
    108
    Thanks
    0
    Thanked 3 Times in 3 Posts
    unlikely... your not using the fuel your injectors are providing anyway, so lowering the boost would theoretically make it worse

  6. #6
    Forum User verified Feedback Score 6 (100%) MADMarc's Avatar
    Join Date
    Sep 2010
    Owner Since

    Location
    Rancho Cucamonga, CA
    Posts
    776
    Thanks
    56
    Thanked 11 Times in 11 Posts
    Check that fpr. If that's the case, it shouldn't be an expensive fix and is a simple swap

  7. #7
    BUS LENGTHS Feedback Score 1 (100%)
    Join Date
    Sep 2010
    Owner Since

    Location
    penn, PA
    Posts
    204
    Thanks
    32
    Thanked 2 Times in 2 Posts
    how can i check it?

  8. #8
    Member verified
    supporter
    Feedback Score 0 DocWalt's Avatar
    Join Date
    Sep 2010
    Owner Since
    Oct '08 - Oct '10

    Location
    Royersford, PA
    Posts
    3,500
    Blog Entries
    1
    Thanks
    796
    Thanked 394 Times in 277 Posts
    plumb in a fuel pressure gauge. I'd worry more about what your trims and O2s are doing to see if it's a dead O2 sensor, or if there's another underlying issue.

  9. #9
    Twin Turbo verified Feedback Score 5 (100%) GTOJOE's Avatar
    Join Date
    Sep 2010
    Owner Since
    2007

    Location
    Melbourne, Australia
    Posts
    2,155
    Thanks
    79
    Thanked 92 Times in 76 Posts
    A faulty AFM could also cause this couldn't it?
    1990 JDM GTO TT with Vi-PEC plug-in V44 EMS, TD04-13T's, 3SX Downpipe, MP Hi-flow cat, ARC SMIC's, Aeromotive Stealth 340LPH pump, Fuelab 515 FPR, Ninja Performance 75amp hotwire kit, oohnoo fuel loop & rail adapters, Nylon braided ethanol fuel line, NGK AFX Wideband, K&N FIPK, Iridium plugs, HKS Twin Power DLI, Turbo XS racing BOV, 3SX poly mounts, Custom 280km/h speedo.

    Waiting install
    Injector Dynamics 725cc Injectors.

    Build Thread

  10. #10
    Better than that "other" place Not Verified Feedback Score 2 (100%) x2xtreme360's Avatar
    Join Date
    Sep 2010
    Owner Since

    Location
    Cazenovia, NY
    Posts
    527
    Thanks
    0
    Thanked 32 Times in 14 Posts
    Do you have a logger? That would point to the issue real quick.

    I don't see how it would be possible to be running lean, then hotwire the pump and see 5-10mpg due to overrunning the FPR. I hotwired my pump and saw a pressure increase, but I barely saw a change in my MPG. Something else is going on here.

    Vacuum reduction, Powdercoated misc, cruise relocate, Evo9 BOV, Custom catch cans, Russell fuel filter, SS braided fuel lines, High flow fuel loop, Autogage fuel gauge, Catless DP, DNP Y-pipe, Fuel pump hotwire.

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
3000GT / Stealth / GTO Resources
3000GT / Stealth / GTO / Multi-site Classifieds
3000GT/Stealth/GTO Event Pages
3S National Gathering
East Coast Gathering
Upper Mid-West Gathering
Blue Ridge Gathering
3000GT/Stealth/GTO Clubs and Groups
Michigan 3S
MInnesota 3S
Wisconsin 3S
Iowa, Nebraska, Kansas 3S
North California 3000GT/Stealth
United Society of 3S Owners
3000GT/Stealth/GTO Forums
3000GT/Stealth International
3000GT/Stealth/GTO Information and Resources
Team 3S
3000GT / Stealth / GTO Information
daveblack.net
The 3000GT/Stealth/GTO Web History Project
3000gt.com
3000GT / Stealth International WWWboard Archive