Page 1 of 4 123 ... LastLast
Results 1 to 10 of 32

Thread: Car dies while turning

  1. #1
    I Kill Threads verified Feedback Score 1 (100%) Goallie11's Avatar
    Join Date
    Sep 2010
    Owner Since
    2008

    Location
    Wichita KS
    Posts
    275
    Thanks
    3
    Thanked 17 Times in 15 Posts

    Car dies while turning

    This has happened to me a couple times, most recently today but it hasnt done it in a while.

    Twice its happened while going to the gas station and slowing from 45 to a righthand turn. Today it died right as i started turning, and i believe the last couple times its been during the same sequence. What should i do?
    1992 3000GT VR-4
    DR650s,Denso 550 injectors, Walbro 255, Emanage Blue,3SX Cat Eliminator Downpipe,Short Shifter,DNP Hardpipe Kit,HKS SSQV,Underdrive pulley,Carbotech slotted rotors,RPS Lightweight Flywheel, Maximal Solid Mounts

  2. #2
    Forum User Feedback Score 0 reallyxxxxxxloud's Avatar
    Join Date
    Sep 2010
    Owner Since
    2005

    Location
    Brisbane Australia
    Posts
    183
    Thanks
    14
    Thanked 17 Times in 15 Posts
    Firstly check all mechanicals aren't hitting any loose wiring etc other than that It could very well be a vacuum leak (my first thought)... Also check the Idle Air Controller is working and make sure the power steering pump isn't putting to much strain on the engine (it may need replacing).
    "Video games don't affect kids, I mean if Pacman affected us as kids, we'd all be running around a darkened room, munching pills and listening to repetitive music."

    PIONEER-ODR RS-K1/C-100/C-200/RS-P50 X2/RS-P1/RS-M1
    DIAMOND-AUDIO HEX 8" X2/HEX SILK DOME TWEETERS X4/D7-401 AMP X2/D7-402 X1/D7-152 AMP X1/D7-104 AMP X1 ETON 4-300/25HEX 4" X4 AUDIO-CONTROL EPIC-160
    ECLPISE 10" TITANIUM (SUBSONICS) X2 SW9102
    PHOENIX-GOLD 12" CYCLONES (INFRASONICS) X2 DC SERVOS http://webfaq.phoenixphorum.com/cyclone.htm
    FUSION 7 COLOUR L.E.D KITS X4 2 MODIFIED. Intergrated lighting through out install.
    1994-MITSUBISHI-GTO-TWIN-TURBO-4WD-4WS-FULLY OPTIONED-SERIOUSLY being MODIFIED

  3. #3
    Member verified Feedback Score 2 (100%) blindmist's Avatar
    Join Date
    Sep 2010
    Owner Since
    Aug 15, 2005

    Location
    Texas
    Posts
    698
    Thanks
    15
    Thanked 45 Times in 28 Posts
    Just a question, is your battery tied down? I ran without mine tied down for a bit, eventually ended up pulling a wire loose and I lost my ground. :P

    I would make a right turn, it would die, I would make a left turn and be ok. lol

  4. #4
    Here for the party Not Verified Feedback Score 1 (100%) CoreyB's Avatar
    Join Date
    Sep 2010
    Owner Since
    2006

    Location
    Canaan NH
    Posts
    1,748
    Thanks
    366
    Thanked 108 Times in 89 Posts
    Either the IAC is bad or the single wire that goes to the pump came unplugged. Does your idle raise when you turn on the AC.

  5. #5
    I Kill Threads verified Feedback Score 1 (100%) Goallie11's Avatar
    Join Date
    Sep 2010
    Owner Since
    2008

    Location
    Wichita KS
    Posts
    275
    Thanks
    3
    Thanked 17 Times in 15 Posts
    I actually just thought it might be my battery, it's tied down but the terminals are pretty coroded, I need to replace them.

    It does raise the idle with the AC on, but where is this wire and controller so I can check it? How can I check that the power steering pump isn't putting too much of a drain on the engine?

    This dying is such a rare occurrence that I've never checked for a cause before.

  6. #6
    Member verified Feedback Score 2 (100%) blindmist's Avatar
    Join Date
    Sep 2010
    Owner Since
    Aug 15, 2005

    Location
    Texas
    Posts
    698
    Thanks
    15
    Thanked 45 Times in 28 Posts
    With the car idling sitting still, turn the wheel all the way in both directions, hold the full turn in each direction for about 5s, this will put a full load on the PS system. If your car is still running, you are probably ok with the IAC. The other thing to check is the PS switch for the IAC.

    IAC is on the Throttle Body.

    http://www.stealth316.com/2-isc-iac.htm



    DSM's are identical to ours.
    Last edited by blindmist; 09-29-2010 at 11:40 AM.

  7. #7
    Here for the party Not Verified Feedback Score 1 (100%) CoreyB's Avatar
    Join Date
    Sep 2010
    Owner Since
    2006

    Location
    Canaan NH
    Posts
    1,748
    Thanks
    366
    Thanked 108 Times in 89 Posts
    If the idle raises with the AC on then the IAC is fine. Like Blindmist said while turning the whell sitting still the idle should raise as well. If it doesnt then the wire at the PS pump probably fell off.

  8. #8
    I Kill Threads verified Feedback Score 1 (100%) Goallie11's Avatar
    Join Date
    Sep 2010
    Owner Since
    2008

    Location
    Wichita KS
    Posts
    275
    Thanks
    3
    Thanked 17 Times in 15 Posts
    Ah ok thanks guys, i have noticed recently that my revs only sometimes raise when i turn whereas before they always did. I'll check to see if that wires fallen off after class.

  9. #9
    Member verified Feedback Score 2 (100%) blindmist's Avatar
    Join Date
    Sep 2010
    Owner Since
    Aug 15, 2005

    Location
    Texas
    Posts
    698
    Thanks
    15
    Thanked 45 Times in 28 Posts
    Yeah, pretty much all the info I gave you with the PS, IAC, and battery should help you get this solved. I HAVE FAITH IN YOU!!

  10. #10
    I Kill Threads verified Feedback Score 1 (100%) Goallie11's Avatar
    Join Date
    Sep 2010
    Owner Since
    2008

    Location
    Wichita KS
    Posts
    275
    Thanks
    3
    Thanked 17 Times in 15 Posts
    K tried the PS pump test and it raised the idle and kept running, so the problem isn't there. I also check the battery and the terminals are still tight, but really corroded. So do need to replace them, but idk if that corrosion can cause this. The IAC must be working too cus the idle raises with the AC on, so any more thoughts?

Page 1 of 4 123 ... LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
3000GT / Stealth / GTO Resources
3000GT / Stealth / GTO / Multi-site Classifieds
3000GT/Stealth/GTO Event Pages
3S National Gathering
East Coast Gathering
Upper Mid-West Gathering
Blue Ridge Gathering
3000GT/Stealth/GTO Clubs and Groups
Michigan 3S
MInnesota 3S
Wisconsin 3S
Iowa, Nebraska, Kansas 3S
North California 3000GT/Stealth
United Society of 3S Owners
3000GT/Stealth/GTO Forums
3000GT/Stealth International
3000GT/Stealth/GTO Information and Resources
Team 3S
3000GT / Stealth / GTO Information
daveblack.net
The 3000GT/Stealth/GTO Web History Project
3000gt.com
3000GT / Stealth International WWWboard Archive